[ Log In ]
[ Register ]

Question #: 14580

Question: Backlash correction is not reflected in Mach3 Turn. Is there a way to reflect it?

Current Solution

Mach3Turn has backlash settings under Config -> Backlash. You will be able to set backlash parameters in distance for each axis and/or by backlash speed percentage of Max. Make sure to enable the backlash compensation by clicking on the Backlash Enabled checkbox.

It is highly recommended that you resolve any backlash in the mechanics of the machine rather than relying on the software to compensate for backlash.

Respond:

Other Possible Solutions to this Question

  • IS THERE A WAY TO GET RID OF THE PARALLEL CABLE AND SOMEHOW USE USB ?

    If you select the Settings Page and select or tick Auto Limit Override - this will allow you to back off the switch.

    Additional Information:
    limit and home switch

    Click the link to add information to this solution:
    IS THERE A WAY TO GET RID OF THE PARALLEL CABLE AND SOMEHOW USE USB ?

  • the bluechik - IS there a 3D Touch Scanning to scan in present made items ?

    Yes, you can use a touch probe with our machines as it is really independent of the machine structure, mechanical components and motion electronics, for the most part. We don't currently sell touch probes, however, but standard touch probes for CNC machines will work fine.

    Click the link to add information to this solution:
    the bluechik - IS there a 3D Touch Scanning to scan in present made items ?

  • I WOULD LIKE TO KNOW IF THERE IS A STORE OR SHOP WHERE CAN SEE THE PRODUCT AND BUY IT?

    If you are located near Houston, Texas area you can stop by our shop. If you are not near us, you can check in our forums, and see if you can find someone in your area that has one of our machines, and would be willing to let you come see it in action.

    Click the link to add information to this solution:
    I WOULD LIKE TO KNOW IF THERE IS A STORE OR SHOP WHERE CAN SEE THE PRODUCT AND BUY IT?

  • I am getting that radus error in Mach3 and changing my IJ setting is not working. Any suggestions?

    What is the actual error that you are seeing in Mach3 and what CAM program are you using? Did you try installing a later version of Mach3 if your's is an earlier version? What post-processing setting are you using in your CAM program?

    Click the link to add information to this solution:
    I am getting that radus error in Mach3 and changing my IJ setting is not working. Any suggestions?

  • Am I supposed to drill a hole in the back of the gantry to access the wires for the motor?? There does not seem to be a way to access the wires for the x axis motor once the gantry back is installed.

    The installation of the motor inside the gantry is mounted and wired before installation of the back plate of the gantry. For Example, our blackFoot machine seen in steps(124/139), you can see that the gantry and and z axis is complete finished before back plate is placed.

    Click the link to add information to this solution:
    Am I supposed to drill a hole in the back of the gantry to access the wires for the motor?? There does not seem to be a way to access the wires for the x axis motor once the gantry back is installed.

  • AM STRUGGLING TO DOWNLOAD THE LINUX EMC2 FREEWARE. MY GET INTERRUPTED AT LAST MINUTE. IS THERE ANOTHER WAY OR PLACE WHERE COULD MAYBE TRY IT FROM?

    You should use the linuxcnc.org site and click on the download menu item. They have an EU mirror as the main download option.

    Click the link to add information to this solution:
    AM STRUGGLING TO DOWNLOAD THE LINUX EMC2 FREEWARE. MY GET INTERRUPTED AT LAST MINUTE. IS THERE ANOTHER WAY OR PLACE WHERE COULD MAYBE TRY IT FROM?

  • HAVE 3D PRINTER THAT WANT TO MAKE CNC ROUTER ,IS THERE ANY GUIDES SHOW ME THE WAY

    What 3d printer do you have?

    Additional Information:
    whiteant

    Click the link to add information to this solution:
    HAVE 3D PRINTER THAT WANT TO MAKE CNC ROUTER ,IS THERE ANY GUIDES SHOW ME THE WAY

  • HOW COMPLEX IS YOUR KIT TO ASSEMBLE, AND MOST IMPORTANTLY - HARD IT SETUP CONTROL THE LASER WITH MACH3?

    The blackTooth Laser cutter and Engraver can be built in a weekend. Take a look at the build instructions and try to determine if you feel you have sufficient capability to put together the laser system.

    Click the link to add information to this solution:
    HOW COMPLEX IS YOUR KIT TO ASSEMBLE, AND MOST IMPORTANTLY - HARD IT SETUP CONTROL THE LASER WITH MACH3?

  • HOW MUCH RADIATION GIVEN OFF BY A CELL PHONE AND THERE ANY WAY TO STOP THE FROM BEING ABSORBED INTO YOURSELF?

    Portable cell phones emit about 0.6 watts of radiofrequency energy, limited primarily by the power of the battery. As with any radiofrequency transmitter, there will be some amount of absorption in the human body; the amount depends on how close you are to the antenna. The Federal Communications Commission (FCC) limits the amount of radiofrequency energy which cell phones can deposit in the body to levels at which no health effects are to be expected. See an article on Cell Phone Safety on this website for more information.

    Gary H. Zeman, ScD, CHP

    Click the link to add information to this solution:
    HOW MUCH RADIATION GIVEN OFF BY A CELL PHONE AND THERE ANY WAY TO STOP THE FROM BEING ABSORBED INTO YOURSELF?

  • Is it possible to manage USB Controller (Breakout) from my own (custom) Windows application? Is there a driver API or smth for that?

    We could not guarantee, nor say, whether or not your current software would be able to utilize the USB breakout board. Our USB breakout board is designed for use with Planet CNC software found here, http://www.planet-cnc.com/index.php?page=software

    As far as we know, this is the only CNC Controller software that operates on a USB breakout controller.

    Click the link to add information to this solution:
    Is it possible to manage USB Controller (Breakout) from my own (custom) Windows application? Is there a driver API or smth for that?

  • WHAT CAUSES ONE OF MY TWO AXIS MOTORS TO STOP WHILE THE MACH3 PROGRAM IS STILL RUNNING

    If one of your stepper motors decides to stop moving and the others are moving during a CNC milling or laser cutting job, then there could be two things that could be causing this.

    - The motor found its limiting torque (usually comes with a not-so-pleasant sound). This is where the control software is trying to move the stepper motor too fast (velocity, or too fast too quickly, acceleration) and the load against the stepper motor (inertia of the machine, or the material against the end mill while milling). Recommended action is to lower the velocity and/or acceleration, and/or lower the feedrate when cutting.

    - There is a wiring issue with the wiring from the driver to the motor. This could be a loose wire, or a chafed wire (or two shorting together). It can also be a loose digital wire from the controller board to the driver. Sometimes wire ties can be the culprit. Recommended action would be to thoroughly inspect the wiring.

    It's probably not the limit switches since that would cause a stop to the entire motion of the cnc router or laser machine.

    Sometimes Mach3 will show a status when something goes wrong, but in cases where the motor is stopping due to its torque limit, then that would not be shown in the status. It's always good to check it anyway.

    Additional Information:
    I need to clarify my situation a little better after going to my shop and trying to run another program on Mach 3. About 15 minutes into the milling process all the motors (2-X axis, Y axis and Z axis)stop but the program continues to run. I stop the program and after a couple of minutes when I try to restart the program all the motors start working again. Then after another 15 minutes or so, all the motors stop again. I checked and rechecked my wiring. This has never happened to me before when running the same programs with the same setups and motor speeds. All of a sudden when I reloaded a program I successfully used before it does this. Do you have any recommendations?

    Additional Information:
    Yeah, it sounds like a more complex issue. Have you tried running in the air without using the spindle. This may be a power related issue.

    Additional Information:
    That's exactly what I did. I ran the program without the router motor on just to see if the motors would get through the whole program but they stopped working after about fifteen minutes and then I was able to start them again after about 3 or 4 minutes. I never had this problem before so you can imagine my frustration especially after ruining a couple of projects on expensive material.

    Additional Information:
    Sure. I can completely understand. Try this: disconnect all but one of the driver from power and digital connection and do the air run. Repeat this for each driver and note your findings. This will rule out the drivers causing a power failure.

    Also, is your stepper motors and drivers on a separate power circuit from the computer?

    Additional Information:
    I will try disconnecting each driver and digital connection, which will be a real pain because it will be hard to access.

    All the stepper motors, drivers and computer are plugged into the same power strip.

    Additional Information:
    Ok, so there is no power failure going on, but I believe it is necessary to test each stepper motor and driver pair individually. Hopefully that will lead to a conclusion.

    Additional Information:
    It will take a little time but I will do it and report back on my findings.

    Additional Information:
    Curious, what machine is exhibiting this problem?

    Additional Information:
    I purchased a BYCNC kit back in 2009 with an approximate cutting area of 2' X 4'. I later changed out the Z-Axis Motor and controller for a larger one and have two X-axis motors and controllers. In 2010 I rebuilt the machine out of birch plywood instead of the particle board that the kit supplied. I sent Patrick pictures to him. The machine never gave me a problem till now.

    Additional Information:
    Thanks for the update. This is Patrick by the way. I answer pretty much all of the Customer Service questions. That machine has given quite a good history.

    Additional Information:
    I love the machine and made a number of samples of my work for my e-commerce site, but I can't start selling product until I know this problem is solved because I will not be able to fulfill orders. I finally got all the electronics out of its enclosed protected area near the machine so that I test each controller as you recommended. I hope the problem can be rectified. Will let you know.

    Additional Information:
    Thanks.

    Additional Information:
    I tested each stepper motor and driver pair individually and they worked so what might be the next step?

    Additional Information:
    Did each stepper motor driver pair work for the full +15 minutes?

    Additional Information:
    Yes, I had them in operation for over 30 minutes.

    Additional Information:
    Ok, well it’s good that the motors and driver are ok. We are now down to the power supply and the breakout board as possible causes for the stop. I have a feeling it may be the power supply where with all three drivers drawing current and the power supply maybe getting too hot. Is the fan in the power supply working? You can also test to see if there is 36 volts on the power supply voltage output (V+ and V-).

    Regarding the breakout board, if you have an oscilloscope, you can test if the driver pulses are outputting, but I would consider this as a last resort after you determine if there is a problem with the power supply.

    Additional Information:
    I tested the power supply with a voltmeter and each output was registering 39-40 volts. I think the problem may be the g-code. I am using V-Carve pro to do design and output to Mach 3 Mill g-code. When I studied the g-code lines I noticed that further into the program the z-axis g-code stopped zeroing out to move to the next part of the carving. In other words both the x and y keep moving and the z just stopped working because there was g-code missing. I think something is missing when the design was converted to g-code. I noticed that when I ran a simpler project it worked without problems so I need to investigate this further.

    Additional Information:
    New Update, Its not the g-code. I started to run the long program and everything was working fine until about 45 minutes into it, all the motors stopped working (but the program was still running) and there was a high pitched hum. When I put my hands on the motors they were all trying to move but it seemed they were all stalled. I turned the power off, gave it a minute and when I turned it back on I was able to move the motors again. Could this be a power supply problem?

    Additional Information:
    It does sound more and more like a power supply problem. Did you test the power supply after the motors stopped?

    Additional Information:
    No, I did not. What should I be looking for.

    Additional Information:
    It’s good that you know the voltage during normal operation, so you have a base understood. If the power supply is the problem, the voltage will be reduced or non existent when measured after the problem.

    Additional Information:
    Also, check to see if the fan is running on the power supply when the motors stop. That may (not absolutely) be an indication.

    Additional Information:
    I'll run another test, check the voltage and fan when the problem occurs and let you know. Thanks for hanging in there with me as we try to resolve the problem.

    Additional Information:
    It’s my pleasure. This service is rarely used and is faster then email. Odd nobody uses it. Any recommendations you can give would be great. No problem using this FAQ to pose ideas as this resolution will be cleaned up later.

    Additional Information:
    It might be that people do not realize you can communicate through the sight like this because they are so used to e-mail and texting. You may want to explain this feature in the customer service section.

    I ran the program this morning and it did not take long before the motors stopped. While operating the voltages for all three motors was 46 volts, when the motors stalled (and again there was a high pitch hum) the voltage went up to 60 volts and the fan on the power supply was operating.

    Additional Information:
    So, the driver work individually, but not all together. There is a high pitch sound when the motors fail. You have noted 60 volts from the power supply and the supply fan remains on. This is a difficult issue to resolve, but it seems to me that your power supply may be bad. The 60v measurement tells me that the current dropped and ohms law tells us that is current drops, volts will rise if the resistance stays the same.

    Additional Information:
    As one last test I am going to test each driver again and let them go through the entire program because it seems that the failure can occur at the beginning or towards the end of the program. When I originally tested ach driver I let them run for about a half an hour and the program takes over an hour to run completely. I just want to make sure that it is not the drivers. I will report back when I finished but as you noted it may be the power supply but I want to make sure.

    Additional Information:
    That’s a great idea.

    Additional Information:
    I just ran the x-axis through the whole program and there was no problem especially since I have two NEMA 23 motors moving that axis. Before I check the Y and Z could having a NEMA 34 on the Z axis with appropriate controller be a problem. I used the larger motor on the z axis because the router I am using is a large 1 1/2 hp. I've run this program in the past with this set-up and have not had a problem.

    Additional Information:
    Having a, say 3.0 amp driver, driving a stepper motor that typically requires a 6 amp driver would not seem to be an issue since the driver is limiting the current draw, but the driver may not be able to handle larger coil and back EMF with the protection on the 3.0 amp driver. With that said, I don’t believe that is the issue in this case.

    Additional Information:
    I don't either because I was able to run this and other complicated programs with this set-up in the past. I will let you know on the y and z axis.

    Additional Information:
    Thanks

    Additional Information:
    I ran the Y axis and z axis separately through the entire program and there was no stopping or problem. I guess the culprit is the power supply and I'll order a new one and hope that resolves the problem.

    Additional Information:
    Yes, that is the most probable cause. Please keep me informed. Thanks!

    Additional Information:
    Received and installed the new power supply. I ran the program with the router on and it worked flawlessly. The program runs for an hour and a half and I did not have a single problem. I guess it was the power supply but I was glad to go through all the diagnostics we discussed before replacing it. I hope this power supply lasts a lot longer than the last one. Thanks much for hanging in there with me and coming up with the solution.

    Additional Information:
    It’s my absolute pleasure and I am so happy to hear that the power supply replacement solved the problem.

    Additional Information:


    Additional Information:
    Y axis stop working X & Z work fine Y axis has two motors have check wiring & connections new breakout board still the same port & Pin set OK dont no were to go next David

    Additional Information:


    Additional Information:
    my cnc plasma cutter will run out the program when cutting. what is the cause?

    Additional Information:
    The cnc plasma question shod be a separate question. Can you pise that question by clicking the customer service live menu button at the top? Thanks.

    Click the link to add information to this solution:
    WHAT CAUSES ONE OF MY TWO AXIS MOTORS TO STOP WHILE THE MACH3 PROGRAM IS STILL RUNNING

  • I HAVE YOUR MACH3 USB BOB, DO YOU GUYS SELL A TORCH CONTROL RELAY CAN WIRE UP TO TURN MY PLASMA ON AND OFF HOW WOULD WIFE THAT TOO THIS BOB?

    We do have a relay board that words like a standard relay.

    Here is the URL of the relay board that we offer:

    https://www.buildyourcnc.com/item/electronicsAndMotors-breakout-Relays-relay-board-250V-12A-5V

    Click the link to add information to this solution:
    I HAVE YOUR MACH3 USB BOB, DO YOU GUYS SELL A TORCH CONTROL RELAY CAN WIRE UP TO TURN MY PLASMA ON AND OFF HOW WOULD WIFE THAT TOO THIS BOB?

  • The plans available for download for the "whiteAnt 3D Plastic Printer" do not have dimensions. Are the dimensions shown in the book? Is there a DWG file available?

    The plans for the whiteAnt 3D Printer will have the dimesions, and the dimensions will be on the individual pieces(cut to spec). The machine is relatively small, so maybe you expected the size(dimensions) to be larger.

    Click the link to add information to this solution:
    The plans available for download for the "whiteAnt 3D Plastic Printer" do not have dimensions. Are the dimensions shown in the book? Is there a DWG file available?

  • I'M CURIOUS IF THESE SYSTEMS WILL ENGRAVE LETTERING ACCURATELY WITHOUT BACKLASH?

    The machines have minimal to no backlash depending on how you apply the machine. Since the cnc machines use roller chain on the x and y axes, and the roller chain is tensioned, the backlash is nearly eliminated. I say nearly because the if you control the machine in a way that there will be excessive load on the end mill, then the machine could have a tendency to spring to one side or the other because of the length of tensioned roller chain. The movement is minor and can be eliminated with the proper control of the machine.

    Click the link to add information to this solution:
    I'M CURIOUS IF THESE SYSTEMS WILL ENGRAVE LETTERING ACCURATELY WITHOUT BACKLASH?

  • Is there a diagram or schematic showing which pin on the 3D printer driver is ABCD?

    You can find a diagram that describes the pin-out for the 2.5 am Driver that is intended for the 3D Printer Main Board, but can be used as a standalone driver as well.

    Additional Information:
    Where is the diagram located?

    Click the link to add information to this solution:
    Is there a diagram or schematic showing which pin on the 3D printer driver is ABCD?

  • Is there a warranty on the NEMA 34 651 Oz-in stepper motors you sell?

    Yes, we honor a one year warranty on the NEMA 34 651 oz-in stepper motor.

    Click the link to add information to this solution:
    Is there a warranty on the NEMA 34 651 Oz-in stepper motors you sell?

  • What are the overall dimensions of the USB interface board? Is there a CAD model available?

    The dimensions for our USB breakout board are:

    L: 2.745"/ 69.723mm
    W: 2.244"/ 56.9976mm
    H: .501"/ 12.7254mm

    Currently we do not have a CAD model on hand.

    Click the link to add information to this solution:
    What are the overall dimensions of the USB interface board? Is there a CAD model available?

  • IS IT OK TO LEAVE THE VACUUM PRESSURE CONTROLLER PLUGGED IN ALL TIME WHEN PUMP SWITCHED OFF?

    I don't see anything in the datasheet for the relay that indicates an overheat condition. While the relay is engaged, the power consumption is 400 mW and I don't believe this is enough to raise the temperature faster than the heat dissipation from the metal on the leads through convection or radiation outside of the rated temperature working ranges providing that you maintain an ambient temperature range within -40°C to 85°C (with no icing or condensation).

    http://www.omron.com/ecb/products/pdf/en-g2rl.pdf

    Click the link to add information to this solution:
    IS IT OK TO LEAVE THE VACUUM PRESSURE CONTROLLER PLUGGED IN ALL TIME WHEN PUMP SWITCHED OFF?

  • I need info on connecting my vfd to run via mach3. Any videos please? Thanks.

    I will be making a video on controlling the VFD via Mach3 shortly.

    Click the link to add information to this solution:
    I need info on connecting my vfd to run via mach3. Any videos please? Thanks.

Get Help with:
This Product
Orders
Tech Support
Sales
This Product
Order Query
Tech Support
Sales
Not logged in. Log In Register
Track Order(s)
View Order(s)
I Want to Schecule a One-On-One Paid Tech Support Session
Book an Appointment Pertaining to a BuildYourCNC Product (Free)
Ask a Quesion Below (Free):
Book an Appointment Pertaining Other Equipment ($60/half hour)
Book an Immedite Appointment Pertaining Other Equipment ($120/half hour)
Ask a Quesion Below (Free):
Waiting for response... I may not answer immediately, but I was notified on my cellular phone so my response is forthcoming. If I don't respond immediately, you can always go to the [My Account] page to see all of our chats at any time.