[ Log In ]
[ Register ]

Question #: 895

Question: delivered Stepper motors do not have the same colored wires as book/videos. What wires to to connect to what?

Current Solution

You will need to use the datasheets or instructions on the product page of the actual motor you have. For instance, if you have the 425 oz-in motors, you can go here: https://www.buildyourcnc.com/item/electronicsAndMotors-nema24-425ozin

Click on the link for the datasheet, or look in the instruction steps and you will find a wiring diagram. If the datasheet gives you an option for bipolar parallel connection scheme, use that one, otherwise, there is probably only one diagram, so you will need to use that one.

Respond:

Other Possible Solutions to this Question

  • I HAVE ONE OF YOUR SMALLER STEPPER MOTORS RUNNING MY X AXIS BRIDGE CRANE AND IF IT IS MOVED TO FAST THE MOTOR SOUNDS LIKE SKIPPING STEPS WILL 651OZ REQUIRE A DIFFERENT POWER SUPPLY CONTROLER?

    Yes, the 651 oz/in motor requires a driver that is compatible to the motors (the motor will draw 6 amps max and the driver paired with this motor will be able to allow for a 6 amp draw). I would also recommend a 36 volt power supply for better high velocity performance.

    Click the link to add information to this solution:
    I HAVE ONE OF YOUR SMALLER STEPPER MOTORS RUNNING MY X AXIS BRIDGE CRANE AND IF IT IS MOVED TO FAST THE MOTOR SOUNDS LIKE SKIPPING STEPS WILL 651OZ REQUIRE A DIFFERENT POWER SUPPLY CONTROLER?

  • I HAVE THE REDFLY SYSTEM AND A 2.2KW SPINDLE - 110V HOW DO CONNECT SPINDAL?

    It is not necessary to connect the spindle VFD (Variable Frequency Drive also called an Inverter) to the computer or CNC motion electronics. The VFD can be controlled independently using the control panel on the VFD. The control panel has the ability to control all aspects of the spindle including Speed, Torque, limits, etc. However, you can connect the VFD to the computer so the CNC control program can control the spindle during the CNC Machine operation. You will need to connect the VFD to the computer via a serial conection (in this case, it is the RS-485 protocol).

    The following are instructions on how to connect the VFD to Mach3 via this RS-485 serial connection.

    The first thing you will need is the dynamic link library to pair with mach3 called the Huanyang VFD Mach3 PlugIn. You can find this file at the mach3 support forum here: http://www.machsupport.com/forum/index.php/topic,14182.0.html

    You will also need to download the Microsoft .net 3.5 framework and install it: https://www.microsoft.com/en-us/download/details.aspx?id=21

    Follow the pdf that comes with the library file, but here is a synopsis of what you need to do (I also added a lot more information that may be useful during this process as the manual does not cover the main connections that need to be done):

    You will need to program your VFD so that it knows how to communicate with mach3 and the computer (go into the programming mode of the VFD and change these parameters):
    - PD001 - value 2 - Enables with communication aspect of the VFD
    - PD002 - value 2 - Enables frequency control from the communcations port
    - PD163 - value 1 - VFD address
    - PD164 - value 1 - Baud rate of 9600 (speed of the communication)
    - PD165 - value 3 - 8N1 RTU - 8 bits (that's the size of the word that gets communicated), N (No parity or no error checking) and 1 (1 stop bit)

    Copy the dll file to the PlugIns folder of mach3.

    Connect the RX and TX lines to your computer. There are a couple ways you can do this, but the recommended way would be to use an FTDI USB device which converts a USB to a serial com port. The device will have Rx and Tx connectors to connect to the VFD terminals with the same labels. This method is recommended since serial ports are not as common in computers these days.

    Next, you will need to configure mach3 to use the plugin library. Start mach3 and click on Menu -> config ->Config Plugins. Enable the new plugin by clicking on the red cross on the left column next to the plug in. Restart mach3 after doing this.

    No you need to configure mach3 to use the HuanyangVFD plugin. Go to the ports & pins configuration and select the spindle setup tab. Make sure that the Disable Spindle Relays checkbox is unchecked. We don't want mach3 to output a signal for a relay since the spindle will start up and turn off within the VFD and not from an external relay.

    Next, go to the HuanyangVFD settings by clicking on Menu -> plugin control -> HuanyangVFD. Set the parameters to the same settings you put into the VFD programming. The com port will be shown as new hardward when you plug in the USB FTDI device. A little bubble will be displayed at the bottom right where it will notify you that a new device is being installed (be patient while windows assigns a com port). Alternatively, you can use the windows device manager to see which port was set for the new USB FTDI device). You may need to restart mach3 several times until you get the correct information displayed in the PD001 and PD002 fields. When the com port is correct and the other parameters, like baud and VFD address is the same as you entered in the programming, then the PD001 and PD002 will show the number 2, otherwise, a 99 will appear which means that communication was not successful.

    You can now control the on/off and RPM of the spindle using the RS485 communication between mach3 and the VFD.

    Additional Information:
    The question was how to connect the spindle to the redfy. I did not receive a VFD.
    I have the redFly system and a 2.2kW Spindle - 110V how do i connect the spindle?

    Additional Information:
    If you received a spindle without a VFD, please contact us asap. Our spindle will not work without a VFD.

    Additional Information:
    Hi, how is this setup in mach4?

    Click the link to add information to this solution:
    I HAVE THE REDFLY SYSTEM AND A 2.2KW SPINDLE - 110V HOW DO CONNECT SPINDAL?

  • I HAVE NEMA 34 MOTORS BUT NEED THE ELECTRICAL COMPONENTS DO YOU A KIT WITHOUT INCLUDED?

    If you are looking for the drivers to pair with NEMA 34 stepper motors, you can find the 6.0 amp drivers here:
    https://www.buildyourcnc.com/item/electronicsAndMotors-stepper-driver-6!0a

    The other electronics to send the signals to the 6.0 amp drivers (the control board that operates with the control software) is subject to personal preference, but here they are listed:

    Our breakout board (works with Mach3 and LinuxCNC and requires a parallel port on your computer):
    https://www.buildyourcnc.com/item/electronicsAndMotors-parallel-breakout-relay

    The PoKeys57CNC (works with Mach3 and Mach4):
    https://www.buildyourcnc.com/item/electronicsAndMotors-electronic-component-breakout-Mach4-mach3-USB-ethernet-Board

    Generic USB breakout board (works with Mach3):
    https://www.buildyourcnc.com/item/electronicsAndMotors-electronic-component-breakout-Mach3-USB-Board

    Additional Information:
    Do I need a driver for every motor or can I use one driver for all four motors

    Additional Information:
    Each motor needs its own driver.

    Click the link to add information to this solution:
    I HAVE NEMA 34 MOTORS BUT NEED THE ELECTRICAL COMPONENTS DO YOU A KIT WITHOUT INCLUDED?

  • WHAT CAUSES ONE OF MY TWO AXIS MOTORS TO STOP WHILE THE MACH3 PROGRAM IS STILL RUNNING

    If one of your stepper motors decides to stop moving and the others are moving during a CNC milling or laser cutting job, then there could be two things that could be causing this.

    - The motor found its limiting torque (usually comes with a not-so-pleasant sound). This is where the control software is trying to move the stepper motor too fast (velocity, or too fast too quickly, acceleration) and the load against the stepper motor (inertia of the machine, or the material against the end mill while milling). Recommended action is to lower the velocity and/or acceleration, and/or lower the feedrate when cutting.

    - There is a wiring issue with the wiring from the driver to the motor. This could be a loose wire, or a chafed wire (or two shorting together). It can also be a loose digital wire from the controller board to the driver. Sometimes wire ties can be the culprit. Recommended action would be to thoroughly inspect the wiring.

    It's probably not the limit switches since that would cause a stop to the entire motion of the cnc router or laser machine.

    Sometimes Mach3 will show a status when something goes wrong, but in cases where the motor is stopping due to its torque limit, then that would not be shown in the status. It's always good to check it anyway.

    Additional Information:
    I need to clarify my situation a little better after going to my shop and trying to run another program on Mach 3. About 15 minutes into the milling process all the motors (2-X axis, Y axis and Z axis)stop but the program continues to run. I stop the program and after a couple of minutes when I try to restart the program all the motors start working again. Then after another 15 minutes or so, all the motors stop again. I checked and rechecked my wiring. This has never happened to me before when running the same programs with the same setups and motor speeds. All of a sudden when I reloaded a program I successfully used before it does this. Do you have any recommendations?

    Additional Information:
    Yeah, it sounds like a more complex issue. Have you tried running in the air without using the spindle. This may be a power related issue.

    Additional Information:
    That's exactly what I did. I ran the program without the router motor on just to see if the motors would get through the whole program but they stopped working after about fifteen minutes and then I was able to start them again after about 3 or 4 minutes. I never had this problem before so you can imagine my frustration especially after ruining a couple of projects on expensive material.

    Additional Information:
    Sure. I can completely understand. Try this: disconnect all but one of the driver from power and digital connection and do the air run. Repeat this for each driver and note your findings. This will rule out the drivers causing a power failure.

    Also, is your stepper motors and drivers on a separate power circuit from the computer?

    Additional Information:
    I will try disconnecting each driver and digital connection, which will be a real pain because it will be hard to access.

    All the stepper motors, drivers and computer are plugged into the same power strip.

    Additional Information:
    Ok, so there is no power failure going on, but I believe it is necessary to test each stepper motor and driver pair individually. Hopefully that will lead to a conclusion.

    Additional Information:
    It will take a little time but I will do it and report back on my findings.

    Additional Information:
    Curious, what machine is exhibiting this problem?

    Additional Information:
    I purchased a BYCNC kit back in 2009 with an approximate cutting area of 2' X 4'. I later changed out the Z-Axis Motor and controller for a larger one and have two X-axis motors and controllers. In 2010 I rebuilt the machine out of birch plywood instead of the particle board that the kit supplied. I sent Patrick pictures to him. The machine never gave me a problem till now.

    Additional Information:
    Thanks for the update. This is Patrick by the way. I answer pretty much all of the Customer Service questions. That machine has given quite a good history.

    Additional Information:
    I love the machine and made a number of samples of my work for my e-commerce site, but I can't start selling product until I know this problem is solved because I will not be able to fulfill orders. I finally got all the electronics out of its enclosed protected area near the machine so that I test each controller as you recommended. I hope the problem can be rectified. Will let you know.

    Additional Information:
    Thanks.

    Additional Information:
    I tested each stepper motor and driver pair individually and they worked so what might be the next step?

    Additional Information:
    Did each stepper motor driver pair work for the full +15 minutes?

    Additional Information:
    Yes, I had them in operation for over 30 minutes.

    Additional Information:
    Ok, well it’s good that the motors and driver are ok. We are now down to the power supply and the breakout board as possible causes for the stop. I have a feeling it may be the power supply where with all three drivers drawing current and the power supply maybe getting too hot. Is the fan in the power supply working? You can also test to see if there is 36 volts on the power supply voltage output (V+ and V-).

    Regarding the breakout board, if you have an oscilloscope, you can test if the driver pulses are outputting, but I would consider this as a last resort after you determine if there is a problem with the power supply.

    Additional Information:
    I tested the power supply with a voltmeter and each output was registering 39-40 volts. I think the problem may be the g-code. I am using V-Carve pro to do design and output to Mach 3 Mill g-code. When I studied the g-code lines I noticed that further into the program the z-axis g-code stopped zeroing out to move to the next part of the carving. In other words both the x and y keep moving and the z just stopped working because there was g-code missing. I think something is missing when the design was converted to g-code. I noticed that when I ran a simpler project it worked without problems so I need to investigate this further.

    Additional Information:
    New Update, Its not the g-code. I started to run the long program and everything was working fine until about 45 minutes into it, all the motors stopped working (but the program was still running) and there was a high pitched hum. When I put my hands on the motors they were all trying to move but it seemed they were all stalled. I turned the power off, gave it a minute and when I turned it back on I was able to move the motors again. Could this be a power supply problem?

    Additional Information:
    It does sound more and more like a power supply problem. Did you test the power supply after the motors stopped?

    Additional Information:
    No, I did not. What should I be looking for.

    Additional Information:
    It’s good that you know the voltage during normal operation, so you have a base understood. If the power supply is the problem, the voltage will be reduced or non existent when measured after the problem.

    Additional Information:
    Also, check to see if the fan is running on the power supply when the motors stop. That may (not absolutely) be an indication.

    Additional Information:
    I'll run another test, check the voltage and fan when the problem occurs and let you know. Thanks for hanging in there with me as we try to resolve the problem.

    Additional Information:
    It’s my pleasure. This service is rarely used and is faster then email. Odd nobody uses it. Any recommendations you can give would be great. No problem using this FAQ to pose ideas as this resolution will be cleaned up later.

    Additional Information:
    It might be that people do not realize you can communicate through the sight like this because they are so used to e-mail and texting. You may want to explain this feature in the customer service section.

    I ran the program this morning and it did not take long before the motors stopped. While operating the voltages for all three motors was 46 volts, when the motors stalled (and again there was a high pitch hum) the voltage went up to 60 volts and the fan on the power supply was operating.

    Additional Information:
    So, the driver work individually, but not all together. There is a high pitch sound when the motors fail. You have noted 60 volts from the power supply and the supply fan remains on. This is a difficult issue to resolve, but it seems to me that your power supply may be bad. The 60v measurement tells me that the current dropped and ohms law tells us that is current drops, volts will rise if the resistance stays the same.

    Additional Information:
    As one last test I am going to test each driver again and let them go through the entire program because it seems that the failure can occur at the beginning or towards the end of the program. When I originally tested ach driver I let them run for about a half an hour and the program takes over an hour to run completely. I just want to make sure that it is not the drivers. I will report back when I finished but as you noted it may be the power supply but I want to make sure.

    Additional Information:
    That’s a great idea.

    Additional Information:
    I just ran the x-axis through the whole program and there was no problem especially since I have two NEMA 23 motors moving that axis. Before I check the Y and Z could having a NEMA 34 on the Z axis with appropriate controller be a problem. I used the larger motor on the z axis because the router I am using is a large 1 1/2 hp. I've run this program in the past with this set-up and have not had a problem.

    Additional Information:
    Having a, say 3.0 amp driver, driving a stepper motor that typically requires a 6 amp driver would not seem to be an issue since the driver is limiting the current draw, but the driver may not be able to handle larger coil and back EMF with the protection on the 3.0 amp driver. With that said, I don’t believe that is the issue in this case.

    Additional Information:
    I don't either because I was able to run this and other complicated programs with this set-up in the past. I will let you know on the y and z axis.

    Additional Information:
    Thanks

    Additional Information:
    I ran the Y axis and z axis separately through the entire program and there was no stopping or problem. I guess the culprit is the power supply and I'll order a new one and hope that resolves the problem.

    Additional Information:
    Yes, that is the most probable cause. Please keep me informed. Thanks!

    Additional Information:
    Received and installed the new power supply. I ran the program with the router on and it worked flawlessly. The program runs for an hour and a half and I did not have a single problem. I guess it was the power supply but I was glad to go through all the diagnostics we discussed before replacing it. I hope this power supply lasts a lot longer than the last one. Thanks much for hanging in there with me and coming up with the solution.

    Additional Information:
    It’s my absolute pleasure and I am so happy to hear that the power supply replacement solved the problem.

    Additional Information:


    Additional Information:
    Y axis stop working X & Z work fine Y axis has two motors have check wiring & connections new breakout board still the same port & Pin set OK dont no were to go next David

    Additional Information:


    Additional Information:
    my cnc plasma cutter will run out the program when cutting. what is the cause?

    Additional Information:
    The cnc plasma question shod be a separate question. Can you pise that question by clicking the customer service live menu button at the top? Thanks.

    Click the link to add information to this solution:
    WHAT CAUSES ONE OF MY TWO AXIS MOTORS TO STOP WHILE THE MACH3 PROGRAM IS STILL RUNNING

  • WHAT TERMINALS ARE USED TO CONNECT THE INVERTER WALL OUTLET?

    Input to VFD:
    240V Active - R
    240V Neutral - S
    Ground - E

    Click the link to add information to this solution:
    WHAT TERMINALS ARE USED TO CONNECT THE INVERTER WALL OUTLET?

  • I purchased a USB Breakout board, motors and drivers, paid for CNC USB Controller Software and I CAN NOT "Slave" an axis, but there is an option to do that. The moment I connect USB Breakout Board "Slave" option becomes shaded and I can no longer select it (becomes not functional). What is going on? Need help asap. Thanks

    I would not recommend slaving an axis using the method of taking an additional axis from the USB interface. Instead, wire both drivers to a single axis on the USB interface. This will insure perfect signal output to both drivers. If you requre the motors to spin in opposite directions, simply wire one of the motors to the driver reversing the coil A and B connections, or use a hex inverter (https://www.buildyourcnc.com/tutorials/Tutorial-Two-Motors-Spinning-Oppositely-On-Single-Axis).

    Click the link to add information to this solution:
    I purchased a USB Breakout board, motors and drivers, paid for CNC USB Controller Software and I CAN NOT "Slave" an axis, but there is an option to do that. The moment I connect USB Breakout Board "Slave" option becomes shaded and I can no longer select it (becomes not functional). What is going on? Need help asap. Thanks

  • WHAT ELECTRICAL CABLE DO I USE TO CONNECT VFD INVERTER SPINDLE?

    The type of wire that should be used between the spindle and the VFD (Variable Frequency Driver also called the inverter) should be of stranded type and we use between 18 and 16 AWG.

    The total current is divided among the three coil wires, therefor a wire gauge of 16 should be sufficient.

    Currently we use 20AWG 4 conductor.

    Additional Information:

    Click the link to add information to this solution:
    WHAT ELECTRICAL CABLE DO I USE TO CONNECT VFD INVERTER SPINDLE?

  • HOW MUCH SILICONE TUBE DO I NEED FOR A GREEN LEAN TO CONNECT THE SPINDLE

    The greenlean requires 56 feet of 1/4 Inside Diameter and 3/8 Outside Diameter silicon tube for the spindle.

    Additional Information:
    20

    Additional Information:
    20

    Click the link to add information to this solution:
    HOW MUCH SILICONE TUBE DO I NEED FOR A GREEN LEAN TO CONNECT THE SPINDLE

  • I HAVE FOLLOWED ALL THE "CNC ELECTRONICS 1 - 9" VIDEOS AND I'M USING ALMOST EXACT SAME COMPONENTS (MOTORS RUN SOUND GOOD) BUT MOTORS ARE RUNING VERY HOT IN JUST 15MIN WITH NO LOAD DONE SOMETHING WRONG OR DO STEPPERS HOT?

    If your motors are hot to the touch, this is normal. Current is being drawn by the motor coils as the motor moves and as the motor stays at a position. If the motor is not using the current in the coils to move (holding it's position), the energy will be translated as heat (rather than motion, sound or light). Even while moving, some of the energy will be lost as heat. Remember that energy cannot be created nor destroyed.

    Click the link to add information to this solution:
    I HAVE FOLLOWED ALL THE "CNC ELECTRONICS 1 - 9" VIDEOS AND I'M USING ALMOST EXACT SAME COMPONENTS (MOTORS RUN SOUND GOOD) BUT MOTORS ARE RUNING VERY HOT IN JUST 15MIN WITH NO LOAD DONE SOMETHING WRONG OR DO STEPPERS HOT?

  • MY COMPUTER DOES NOT HAVE A PARALLEL PORT. HOW DO I INTERFACE WITH THE BREAKOUT BOARD?

    If your computer does not have a parallel port, all you will need is a low cost PCI parallel adapter card (these can be found on amazon for $15-$20). If you plan on using a laptop (not recommended) you can try to find a PCMCIA parallel adapter, but many people have frequent issues with this setup. A more expensive solution would be to purchase a USB smooth stepper board. Unfortunately, we do not supply any of these adapters and cannot attest to their reliability.

    Additional Information:
    ur gay

    Additional Information:

    Click the link to add information to this solution:
    MY COMPUTER DOES NOT HAVE A PARALLEL PORT. HOW DO I INTERFACE WITH THE BREAKOUT BOARD?

  • HOW DO I CONNECT A TOUCH PLATE TO THE BREAKOUT BOARD?

    The instructions on how to do this are found here, in these two videos, http://buildyourcnc.com/PrimeronHomingandLimitSwitches.aspx

    Additional Information:

    Click the link to add information to this solution:
    HOW DO I CONNECT A TOUCH PLATE TO THE BREAKOUT BOARD?

  • MY COMPUTER DOES NOT HAVE A PARALLEL PORT. HOW DO I INTERFACE WITH THE MACHINE?

    If your computer does not have a parallel port, all you will need is a low cost PCI parallel adapter card (these can be found on amazon for $15-$20). If you plan on using a laptop (not recommended) you can try to find a PCMCIA parallel adapter, but many people have frequent issues with this setup. A more expensive solution would be to purchase a USB smooth stepper board. Unfortunately, we do not supply any of these adapters and cannot attest to their reliability.

    Additional Information:
    ur gay

    Additional Information:

    Click the link to add information to this solution:
    MY COMPUTER DOES NOT HAVE A PARALLEL PORT. HOW DO I INTERFACE WITH THE MACHINE?

  • MY COMPUTER DOES NOT HAVE A PARALLEL PORT. WHAT DO I NEED?

    If your computer does not have a parallel port, all you will need is a low cost PCI parallel adapter card (these can be found on amazon for $15-$20). If you plan on using a laptop (not recommended) you can try to find a PCMCIA parallel adapter, but many people have frequent issues with this setup. A more expensive solution would be to purchase a USB smooth stepper board. Unfortunately, we do not supply any of these adapters and cannot attest to their reliability.

    Additional Information:
    ur gay

    Additional Information:

    Click the link to add information to this solution:
    MY COMPUTER DOES NOT HAVE A PARALLEL PORT. WHAT DO I NEED?

  • HOW DO YOU CONNECT THE INVERTER TO AC?

    Input to VFD:
    240V Active - R
    240V Neutral - S
    Ground - E

    Click the link to add information to this solution:
    HOW DO YOU CONNECT THE INVERTER TO AC?

  • IF I PURCHASE A GREENBULL 6X LONG Z CNC MACHINE KIT AND MACH3, WHAT ELSE WOULD BE REQUIRED TO ASSEMBLE THE WORKING MACHINE? HAVE CAD SOFTWARE.

    You will need to build the table unit for your machine. There are instructions on how to do this at the bottom of the product page here, https://www.buildyourcnc.com/Item/cnc-machine-blackFoot-v4
    There is no estimate on how much this will cost though, since there are too many variables involved to do this.

    - PC with parallel port and USB port
    - 20awg stranded wires for the motors - http://www.buildyourcnc.com/electronicscombo.aspx
    - 18awg stranded wires for power supply to drivers
    - 24awg stranded wires for breakout board to drivers
    (location and spacing of components varies from one person to another, so we do not provide cables/wires)
    - General purpose extension cord (cut the female end off) to provide power to power supply
    - USB cable to power breakout board
    - Parallel cable to communicate to breakout board
    - Router
    - (optional - instead of router) Spindle with power inverter http://www.buildyourcnc.com/SpindlesAndAccessories.aspx
    - (if purchasing spindle with inverter) General purpose extension cord (240v) (cut the female end off) to provide power to power inverter
    - End Mill(s) http://www.buildyourcnc.com/ProductsEndMills.aspx
    - CAD, and/or CAD-CAM software (to produce geometry, machine operations, and g-code) http://www.buildyourcnc.com/CNCsoftware.aspx
    - CNC control software (to read g-code and control machine) http://www.buildyourcnc.com/CNCsoftware.aspx

    This answer is applicable to most of our machines with the exception of the greenLean and the blueChick since those machines are equipped with a table structure.

    Click the link to add information to this solution:
    IF I PURCHASE A GREENBULL 6X LONG Z CNC MACHINE KIT AND MACH3, WHAT ELSE WOULD BE REQUIRED TO ASSEMBLE THE WORKING MACHINE? HAVE CAD SOFTWARE.

  • DO NEED TO SQUARE UP THE MACHINE AND IF SO YOU HAVE INSTRUCTIONS OR VIDEO FOR THIS?

    The eyebolts are used in the squaring of the machine. I would use a standard carpenters square and first run the end mill along the edge of the square to first make it parallel with the long axis. Then run the end mill along the other edge with the short axis and adjust the eye bolts and chain according to the angle that the machine is out of square.

    Click the link to add information to this solution:
    DO NEED TO SQUARE UP THE MACHINE AND IF SO YOU HAVE INSTRUCTIONS OR VIDEO FOR THIS?

  • WHAT MOTORS DOES THE BLACK TOOTH USE?
  • WHAT MOTORS DOES THE BLACK TOOTH USE?
  • DON'T WANT TO USE MY OWN MOTORS FOR THE REDLEAF CNC COMPUTER SYSTEM.

    That shouldn't be a problem. I will need the current rating for the motors. We can subtract the price of the motors. and you can add you own. If you want us to solder the cable to the round connectors and them motor, you would need to send the motors to us.

    Let me know and I can send a paypal invoice for the redLeaf without motors.

    Click the link to add information to this solution:
    DON'T WANT TO USE MY OWN MOTORS FOR THE REDLEAF CNC COMPUTER SYSTEM.

Get Help with:
This Product
Orders
Tech Support
Sales
This Product
Order Query
Tech Support
Sales
Not logged in. Log In Register
Track Order(s)
View Order(s)
I Want to Schecule a One-On-One Paid Tech Support Session
Book an Appointment Pertaining to a BuildYourCNC Product (Free)
Ask a Quesion Below (Free):
Book an Appointment Pertaining Other Equipment ($60/half hour)
Book an Immedite Appointment Pertaining Other Equipment ($120/half hour)
Ask a Quesion Below (Free):
Waiting for response... I may not answer immediately, but I was notified on my cellular phone so my response is forthcoming. If I don't respond immediately, you can always go to the [My Account] page to see all of our chats at any time.