[ Log In ]
[ Register ]
NEW: CNC Router PLANS Available for all of our Newest CNC Models!! Click here to "Design Your CNC".

Question #: 13609

Question: My stepper motors stopped working all of a sudden. Mach 3 is running fine, just no signals getting to the motors. The lights on the motor drivers began blinking erratically when this started. Any advice where a problem like this can come from would be greatly appreciated.

Current Solution

The drivers have quite a bit of protection, so you probably won't ruin anything. You motors are jumping and that is just the motors engaging from getting power from the power supply.

There could be many reasons your motors don't turn. Consider these troubleshooting tips:

- If you are using our parallel breakout board, make sure that the step pins are set for active low (config -> Ports and Pins -> Motor Outputs -> the steps pins should be enabled and set active low)

- The parallel breakout board is powered (connect the USB to the computer using a USB cable)

- In Mach3, make sure you have jog enabled (a little green button at thelower middle of the page in the program run screen).

Additional Information:

Respond:

Other Possible Solutions to this Question

Get Help with:
This Product
Orders
Tech Support
Sales
This Product
Order Query
Tech Support
Sales
Not logged in. Log In Register
Track Order(s)
View Order(s)
I Want to Schecule a One-On-One Paid Tech Support Session
Book an Appointment Pertaining to a BuildYourCNC Product (Free)
Ask a Quesion Below (Free):
Book an Appointment Pertaining Other Equipment ($60/half hour)
Book an Immedite Appointment Pertaining Other Equipment ($120/half hour)
Ask a Quesion Below (Free):
Waiting for response... I may not answer immediately, but I was notified on my cellular phone so my response is forthcoming. If I don't respond immediately, you can always go to the [My Account] page to see all of our chats at any time.