[ Log In ]
[ Register ]

Question #: 14693

Question: I'm having a problem with my controller card: I can measure 24 volts going to the card, but when I set Mach3 outputs I reagister no voltage. Please help

Current Solution

Is this regarding the Mach3 USB controller?

Respond:

Other Possible Solutions to this Question

  • I purchased the Mach3 USB controller, however when I ran the test procedure, I get no response from the board, however the light comes on but does not flash when I Press the arrow keys, and measurements with the multimeter shows no voltage on the output connections. the meter shows 24 volts on the 24 volt connection across 24v and DCM. I believe the board is corrupt.

    Does the board's light come on at all? Did you try only connecting the controller to the USB, without the 24V connected to see if the board is functioning?

    Thanks

    Additional Information:
    Hi Patrick, Larry Here, I'm still having the same problem with the new board. When I plug the usb cable in the board, I get the flashing light but when I measure the voltage on the output pins I get no voltage at all. Mach3 says that the pins, 1 thru 4 are enabled and the output is enabled on all the pins just the way I set them, but no joy.

    Click the link to respond:
    I purchased the Mach3 USB controller, however when I ran the test procedure, I get no response from the board, however the light comes on but does not flash when I Press the arrow keys, and measurements with the multimeter shows no voltage on the output connections. the meter shows 24 volts on the 24 volt connection across 24v and DCM. I believe the board is corrupt.

  • Im having software setup problems with my backtooth (mach3) and i seem not to find a solution in the forum. what can i do?

    You can call us, send an email, or pose the specific question on this customer service live that pertains to the issue that you are having.

    Click the link to respond:
    Im having software setup problems with my backtooth (mach3) and i seem not to find a solution in the forum. what can i do?

  • I'm connecting my PCI-e parallel expansion card to my 5 axis parallel port breakout board. However, the 3.3 volts coming out is not triggering servo step. I can measure hi/lo coming out of the parallel port when using Mach 3. Is the low voltage likely the issue or should I look elsewhere?

    In the mach 3 software there is a setting that can be check to allow either a high or low to trigger you motor. In Mach 3 Config/Ports&Pins/MotorOutputs/StepLowA will enable the motor with a low Voltage.

    Adjust the motor outputs to there corresponding step pin/direction pin(if setup is following our diagram):
    Step Dirt
    x 2 3
    y 4 5
    z 6 7

    Click the link to respond:
    I'm connecting my PCI-e parallel expansion card to my 5 axis parallel port breakout board. However, the 3.3 volts coming out is not triggering servo step. I can measure hi/lo coming out of the parallel port when using Mach 3. Is the low voltage likely the issue or should I look elsewhere?

  • I have nearly completed the CNC machine from the book, but I am using it with a USB breakout board, and have no idea how to wire the 6 limit switches to the board. I'm having difficulty following the diagram on the USB breakout board screen. Can someone please help me?

    Sure, the USB interface has a place for 4 axes of limit switches.

    Each axis can have two limit switches: one for the ++ (positive) end and one for the -- (negative) end. The positive end would be the limit switch at the end of the machine that, say the machine has a 4'x8' area, reaches a bit after the 8 foot mark. The negative end would be the limit switch behind the 0 foot location behind the origin. If the origin is in the middle, the negative would be at a little more than the -4 foot end and the positive would be at a bit more than the +4 foot end. Note that you can have more than one switch on each pin where the NC is connected in serial fashion and the NO is connected in parallel fashion (this can be seen on the diagram in the multiple limits switch section). The software configurations for the limits switches are under File -> Settings -> Limit.

    A typical limit switch has three connections on it. These connections consist of COM (common), NC (normally closed) and NO (normally open). The COM would generally go to GND and the NC or the NO would go to the pin. If the NC is used, then the the switch is constantly connected until the switch is pushed (engaged) then the connection from the pin to gnd is broken (open). Use the settings in software to set whether in NC or NO configuration.

    Let me know if this information was helpful (or not) by adding information to this question. Thanks.

    User response:
    Thank you very much for this helpful information. I'm still a little fuzzy on how the 6 limit switches physically connect to each other and to the USB breakout board. You've stated one switch (home) goes to positive and another switch (limit) goes to negative. Are all the GND prongs from all 6 switches connected to each other and going to GND on the breakout board, or no? And the NC prongs, how exactly are they connected to each other? And to the board? There has to be a diagram somewhere shows this visually, no? I don't know how to wire the switches in series or in parallel. I have already physically installed all the switches on the machine and ran the wires to where the board is. Now I just need to know where to plug these wires into the board. Also, taking into consideration that I'm using the Planet CNC software, the only settings I have pertaining to limit switches is "Enable/Disable" for each axis, and the actual limit for each axis. Nothing about NC or NO. Is that only in Mach3?
    Thank you.

    buildyourcnc response:
    On the USB interface, the COM on the switch connects to GND and the NC or NO connects to the input pin (i.e. x++, y--, etc.)

    Limit switch configuration is rather difficult to understand, especially with series and parallel. You can think of series as a single wire going from GND to the axis letter input terminal (i.e. X++ or X--). If the wire is broken, then the circuit is open (or the switch is engaged in a normally closed scenario). Normally closed is like an actual wire, and when engaged, the switch "opens" (breaks the wire). This is why we recommend in some systems that you can put many switches in series on a single pin. When one of the switches is engaged (breaking the connection) then the entire circuit of switches is broken and the machine stops.

    In a parallel scenario, the state of the circuit is always broken until the one of the switches is engaged and the circuit is then closed or connected. The topology looks like a ladder. All the switches connect to both sides of the ladder and the switches are like the runs of the ladder (the horizontal bars that the feet are placed while climbing). Imagine all of the switches broken in this scenario (normally open). It would be like the ladder could be split in two, but if one of the ladder runs (switches) is closed by engaging it, then that run would connect both sides of the ladder and the two sides of the ladder would have a connection.

    There is a diagram on the USB page of the various limit switch configurations. If you need more information (visual and/or otherwise), please let us know and we will immediately add that information to benefit everyone.

    Click the link to respond:
    I have nearly completed the CNC machine from the book, but I am using it with a USB breakout board, and have no idea how to wire the 6 limit switches to the board. I'm having difficulty following the diagram on the USB breakout board screen. Can someone please help me?

  • Hello, After watching the tutorial to set up my spindle in Mach3, My outputs are not working. Any help would be appreciated. Just Simple on/off.

    I created a video that demonstrates the wiring and Mach3 configuration for the Mach3 USB controller. It is the last video on the following webpage:
    https://www.buildyourcnc.com/item/electronicsAndMotors-electronic-component-breakout-Mach3-USB-Board

    If you have a different controller, let me know and I can provide further inforatmion.

    Click the link to respond:
    Hello, After watching the tutorial to set up my spindle in Mach3, My outputs are not working. Any help would be appreciated. Just Simple on/off.

  • I am having trouble connecting the cambam program with my Mach3 to my 4X8 Blackfoot CNC machine. Where can I get help on this issue. Have had my machine since 2015 and have not been able to use it. Thank you

    CamBam specifically creates the g-code (machining operations) instructions to be loaded into Mach3. Make sure in your CamBam g-code file parameters, you are using the Mach3 post processor. If you have already done this, let me know. If you are not sure how to do this, let me know.

    Click the link to respond:
    I am having trouble connecting the cambam program with my Mach3 to my 4X8 Blackfoot CNC machine. Where can I get help on this issue. Have had my machine since 2015 and have not been able to use it. Thank you

  • I bought a 'BuildyourCNC V1' relay board to go with my mach3 usb controller. I have been sent a 'Songle' relay. It's not the one in your picture and it's got different connections, for which there isn't a wiring diagram. The one I ordered says it is 5v, this one seems to be saying it's a 24v unit. Can you please explain what has happened? Thanks

    The Mach3 USB interface board requires 24V relays externally. There are no relays on the mach3 usb board. If you use an external relay on the mach3 usb board, the relay connects to the V+ which is 24V and the output pin is the return.

    Additional Information:
    I understand what you are saying. Does your relay board work with the Mach3 USB board? If not, what relay board do you suggest to work with this usb controller?

    Additional Information:
    Our relay board works with our parallel breakout board. An off the shelf SSR (Solid State Relay) made for 24V should work fine.

    Click the link to respond:
    I bought a 'BuildyourCNC V1' relay board to go with my mach3 usb controller. I have been sent a 'Songle' relay. It's not the one in your picture and it's got different connections, for which there isn't a wiring diagram. The one I ordered says it is 5v, this one seems to be saying it's a 24v unit. Can you please explain what has happened? Thanks

  • I bought a 'BuildyourCNC V1' relay board to go with my mach3 usb controller. I have been sent a 'Songle' relay. It's not the one in your picture and it's got different connections, for which there isn't a wiring diagram. The one I ordered says it is 5v, this one seems to be saying it's a 24v unit. Can you please explain what has happened? Thanks

    The Mach3 USB interface board requires 24V relays externally. There are no relays on the mach3 usb board. If you use an external relay on the mach3 usb board, the relay connects to the V+ which is 24V and the output pin is the return.

    Additional Information:
    I understand what you are saying. Does your relay board work with the Mach3 USB board? If not, what relay board do you suggest to work with this usb controller?

    Additional Information:
    Our relay board works with our parallel breakout board. An off the shelf SSR (Solid State Relay) made for 24V should work fine.

    Click the link to respond:
    I bought a 'BuildyourCNC V1' relay board to go with my mach3 usb controller. I have been sent a 'Songle' relay. It's not the one in your picture and it's got different connections, for which there isn't a wiring diagram. The one I ordered says it is 5v, this one seems to be saying it's a 24v unit. Can you please explain what has happened? Thanks

  • I have a "Based on planet-cnc's diy cnc usb controller", I activated the output signal (mist, coolant or spindle) in the planetcnc software but at the output there is no voltage, what can I do to turn on this elements?

    On the Planet-CNC board, the Mist, Spindle and Coolant outputs will require a relay to switch on those devices. Test one of those terminals with a multi-meter (Mist, Coolant, or Spindle). Each of these terminals have a GND next to the terminal for the device.

    Test the voltage across the GND to the terminal with the arrow that you want to test. Go to the software and click on the device you want to test (mist, coolant or spindle) and note the voltage. If no voltage is output then check under the board to where the terminals are soldered. Re-test the terminals across the solder joints rather than the terminal block wire inputs. If you get a voltage, then there is a problem with the terminal block. If you don't get a voltage, then the board is not functioning properly.

    Additional Information:
    I activated the output signal.. I did the tests indicated and I did not get voltage. I heated the welds of the three outputs and now works coolant but no mist or spindle, what should I do?

    Additional Information:
    There are probably cold joints on the board at the chip or the resistors on the traces for those terminals. You can send the board back to us and we will repair and test the board.

    Click the link to respond:
    I have a "Based on planet-cnc's diy cnc usb controller", I activated the output signal (mist, coolant or spindle) in the planetcnc software but at the output there is no voltage, what can I do to turn on this elements?

  • I have a "Based on planet-cnc's diy cnc usb controller", I activated the output signal (mist, coolant or spindle) in the planetcnc software but at the output there is no voltage, what can I do to turn on this elements?

    On the Planet-CNC board, the Mist, Spindle and Coolant outputs will require a relay to switch on those devices. Test one of those terminals with a multi-meter (Mist, Coolant, or Spindle). Each of these terminals have a GND next to the terminal for the device.

    Test the voltage across the GND to the terminal with the arrow that you want to test. Go to the software and click on the device you want to test (mist, coolant or spindle) and note the voltage. If no voltage is output then check under the board to where the terminals are soldered. Re-test the terminals across the solder joints rather than the terminal block wire inputs. If you get a voltage, then there is a problem with the terminal block. If you don't get a voltage, then the board is not functioning properly.

    Additional Information:
    I activated the output signal.. I did the tests indicated and I did not get voltage. I heated the welds of the three outputs and now works coolant but no mist or spindle, what should I do?

    Additional Information:
    There are probably cold joints on the board at the chip or the resistors on the traces for those terminals. You can send the board back to us and we will repair and test the board.

    Additional Information:
    If you want to troubleshoot this yourself, take a very close look at the traces from the terminal and follow them to the tiny resistors, then to the legs of the chip. If you see any bad or bridged solder joints, then those will need to be re-touched. It will take a somewhat experienced soldering individual to accomplish this task and will require flux to make sure the solder joints are fully joined.

    Click the link to respond:
    I have a "Based on planet-cnc's diy cnc usb controller", I activated the output signal (mist, coolant or spindle) in the planetcnc software but at the output there is no voltage, what can I do to turn on this elements?

  • I have your Nema 24 electronics kit and am having problems with the Z axis dropping over time. I am using a PC 8902 motor. Any ideas on what the problem is? What should be the motor tuning values in Mach3? Thanks

    Make sure all your bolts/screws are tighten correctly and if using a lead screw make sure your anti-backlash nut is not offset. Now a default setting will be 10101100 for your driver dip switch settings and in motor tuning (mach3) 1600 steps per, 400.02 velocity, 4 in acceleration. now the acceleration and velocity can be adjusted to move your machine faster, but if set to high they could stall. Make sure you have the correct wiring from your motor to your driver (https://www.buildyourcnc.com/Documents/PN.SM60HT86-2008BF-U%20(inhouse%20PN.60BYGH303-13)%20(1).pdf).

    Click the link to respond:
    I have your Nema 24 electronics kit and am having problems with the Z axis dropping over time. I am using a PC 8902 motor. Any ideas on what the problem is? What should be the motor tuning values in Mach3? Thanks

  • I have big problem with my water colling system on CNC. I think some things are internally clogged on water cooled spindle.. It's not debris, It's heavy than debris.. Please help me immediate if you can..

    Have you tried to blow the debris out with a compressor?

    Additional Information:
    yes i tried with a air compressor but it not work's. I'm in trouble with this problem. how can i open it?

    Click the link to respond:
    I have big problem with my water colling system on CNC. I think some things are internally clogged on water cooled spindle.. It's not debris, It's heavy than debris.. Please help me immediate if you can..

  • I am having trouble with my cutting precision. I can cut a 1" box within 0.005" accuracy, but when I try to cut something with a 6" profile, it cuts almost 0.125" heavy. Any help would be greatly appreciated.

    Dealing with a larger offset when cutting a larger object, try calibrating your machine accordingly (

    ) now you will have to do the last couple of steps a few times to get your machine as accurate as possible.
    Also if this does not correct your issue, try looking at the tightness of your x/y/z - axis chain, bearings, and also your sprocket/rod, the chain must be viewed as a bicycle chain if too tight it might snap when the machine moves but if to loose then it will be off. The rod is not totally flat where the set screws are suppose to hold down the rod, so sanding it to a flatter surface section might fix the offset.

    Additional Information:
    accuracy

    Click the link to respond:
    I am having trouble with my cutting precision. I can cut a 1" box within 0.005" accuracy, but when I try to cut something with a 6" profile, it cuts almost 0.125" heavy. Any help would be greatly appreciated.

  • HI..I am having a problem with my machine going off axis and not returning to zero

    Hi, can you elaborate on what you mean off axis? If the CNC router is milling correctly and then suddenly in a location that you would not expect, then you are exceeding the torque of the stepper motors and stalling. If the cnc router stalls, then the cnc router will continue but the software controlling the cnc router will not have the correct position of the cnc router.

    If this is the case, then you need to either reduce the acceleration, reduce the velocity, or both. Does the problem occur during the milling process or during the jogging (rapids)?

    Click the link to respond:
    HI..I am having a problem with my machine going off axis and not returning to zero

  • i have a breakout usb controller iam using a spindle output to active a relay 5V but it didnt work.... whats the problem, what else i need to active that realy 5v 10A?

    To control a spindle using the USB CNC interface, you will need a relay board that contains a transistor that can activate the relay with a power source with enough current that can activate the relay. This video explains all of the information you will need to develop this relay circuit:

    &index=44&list=PLE72E4CFE73BD1DE1

    Click the link to respond:
    i have a breakout usb controller iam using a spindle output to active a relay 5V but it didnt work.... whats the problem, what else i need to active that realy 5v 10A?

  • Using USB Controller Board with Planet-CNC software. The S/W recognizes limit switches but not soft limits. Help?

    "Soft limits are used to decelerate machine to stop before machine is stopped hard way at limit switch or before it crashes. I recommend "Soft Limits Decelerate" and "Soft Limits Strict" settings are also checked. Sometimes we need to disable soft limits and there is a command for this in menu "Machine/Soft Limits". When soft limit is triggered position display will be yellow."

    Are the soft limits "grayed out"?
    Here is a link to a very useful forum post from the Planet-CNC crew:
    http://www.planet-cnc.com/faq/machine_setup/



    Additional Information:
    i keep getting scratches when engraving pictures on dog tags

    Click the link to respond:
    Using USB Controller Board with Planet-CNC software. The S/W recognizes limit switches but not soft limits. Help?

  • My pokeysCNC board creates and analog signal of 0-10V for 0 to 24000 spindle rpm just like it should from Mach3. However, when the spindle is on, the voltage only gets to about 3.8V for 24000 rpm. It seems like the vfd is drawing more current than the pokeyscnc analog output can produce. It there an easy solution to this problem?

    Do you have the Pokeys57CNC connected to a 24V external power supply?

    Additional Information:
    Yes, a 24V external power supply with the jumper positioned. I'm using the ethernet port so the 24v is the only source of power. I plan to measure the amp draw when I have a chance to see how much the vfd is drawing on the analog out.

    Additional Information:
    Further information. The resistance across the terminals on the vfd is 22k ohms. With an independent 0-10v current source I can run the spindle from 20 to 400 Hz. The PokeysCNC only gets to 3.8v with the vfd attached (and the vfd is at 150 Hz) compared to 10v when the vfd is not attached. The power to the PokeysCNC is steady at 24.18 V, so I'm not maxing out the power supply. Still looking for thoughts on what might be going on?

    Additional Information:
    And the other thing - The measured amperage is 0.17 mA for the 0-10 V signal (which makes perfect sense for 3.7 V and 22k Ohms).

    Additional Information:
    Just to bring finality to this issue - I added a 2.2 microfarad capacitor across the 0-10V input terminal (from signal to ground). This solved the issue. Evidently, it was an electrical noise issue.

    Click the link to respond:
    My pokeysCNC board creates and analog signal of 0-10V for 0 to 24000 spindle rpm just like it should from Mach3. However, when the spindle is on, the voltage only gets to about 3.8V for 24000 rpm. It seems like the vfd is drawing more current than the pokeyscnc analog output can produce. It there an easy solution to this problem?

  • Re: From Sketchup ... There are always software version problems with different computer setups. Please, what is the specific hardware and software used to make this system?

    I need more information to properly answer this question. Are you referring to computer hardware to make SketchUp work, or how to setup a CNC machine to work with SketchUp?

    Click the link to respond:
    Re: From Sketchup ... There are always software version problems with different computer setups. Please, what is the specific hardware and software used to make this system?

  • I trying to setup your USB Controller card. The planetcnc does not load the card, no driver for usb card. Using windows 8.1.

    To install the USB breakout board, there will be no driver to install nor any pop-up will be viewed in your windows task-bar, except only to notify that a USB device has been connected.

    If you have planet-cnc installed it should automatically ask for a license number, which if you don't have you will continue without entering any numbers. Please read carefully since there is a pop-up that can erase the entire firmware on your board, and you will basically have a dead board.

    Please email customerservice@buildyourcnc.com for further assitance.

    Additional Information:
    For Windows 8.1 you need to follow special driver installation steps. Download Planet-cnc software MANUAL and scroll down to that paragraph (without it you will not be able to install and use your board).

    Click the link to respond:
    I trying to setup your USB Controller card. The planetcnc does not load the card, no driver for usb card. Using windows 8.1.

Get Help with:
This Product
Orders
Tech Support
Sales
This Product
Order Query
Tech Support
Sales
Not logged in. Log In Register
Track Order(s)
View Order(s)
I Want to Schecule a One-On-One Paid Tech Support Session
Book an Appointment Pertaining to a BuildYourCNC Product (Free)
Ask a Quesion Below (Free):
Book an Appointment Pertaining Other Equipment ($60/half hour)
Book an Immedite Appointment Pertaining Other Equipment ($120/half hour)
Ask a Quesion Below (Free):
Waiting for response... I may not answer immediately, but I was notified on my cellular phone so my response is forthcoming. If I don't respond immediately, you can always go to the [My Account] page to see all of our chats at any time.